Cat Evolution
Petfun: Automatic Feeder flashing red light

Knowledge Base

Petfun: Automatic Feeder flashing red light

If your Petfun automatic feeder is showing a red flashing light, it maybe one of the following reasons:

  1. there is food in the hopper
  2. if the food dispenses. Check by pushing the SET button next to the flashing light, to manually feed
  3. if the food only partly, or not all, dispenses, as it jams
  4. if there is too much food dispensed, covering the sensor in the chute
  5. if the sensor in the chute has food or something on it
  6. if there is a fault with the electronics

A simple way to check if the food is dispensing, is to use the SET button to action dispense of food. 

Check by pushing the button next to the flashing light, to manually feed.

If you have only a little food in the hopper, you can see the motion and dispense better than if the hopper is full.

You can also test if the hopper rotator is working, by removing the inner sleeve, and plugging in, turning on with the red light solid,  and pressing set to see if the actual turning part moves. Note that you will get a red flashing light, but that is not a problem, as you are just checking if the rotation occurs ok. 

After checking it is not a food related issue, and you still have a flashing red light, check to see if the sensor in the chute need a light clean.  The sensors are located inside the outfall (black) chute, where the food drops down, and can be easily accessed from the front of the Feeder, without opening it.  They are a little difficult to see, as they are very small, and you may find looking through the camera on your mobile phone helpful, looking at the left hand side as this is where the sensor beam is emitted from (receptor on right). The beam is a small red light.

To clean, turn off the feeder with the rear switch, and unplug  completely from the power.  Try wiping the chute outfall with a dry paper towel. Clean the actual sensor with a dry cotton bud/ear bud or Q tip.

Plug in and turn on - the feeder should reconnect itself over a minute or two - first the red light, then the green.

Usually, settings would be saved.

If you have further issues, please contact Customer Service for assistance.

Leave us a message
    Help